You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
lokinet/debian/patches/0003-Remove-ccache.patch

27 lines
721 B
Diff

From: Jason Rhinelander <jason@imaginary.ca>
Date: Thu, 25 Jul 2019 19:10:21 -0300
Subject: Remove ccache
The default pbuilder install already puts ccache in the path, and having
this results in double-ccache invocation which looks odd in the build
log.
---
CMakeLists.txt | 5 -----
1 file changed, 5 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 054aa57..4b2f525 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,10 +1,5 @@
cmake_minimum_required(VERSION 3.5.1) # xenial's cmake version
-find_program(CCACHE_PROGRAM ccache)
-if(CCACHE_PROGRAM)
- set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE "${CCACHE_PROGRAM}")
-endif()
-
set(PROJECT_NAME lokinet)
project(${PROJECT_NAME} C CXX)