You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
lokinet/debian/patches/0001-make-check-runs-test-s...

39 lines
1.1 KiB
Diff

From: Jason Rhinelander <jason@imaginary.ca>
Date: Thu, 25 Jul 2019 18:32:13 -0300
Subject: 'make check' runs test suite
debhelper prefers a make test target, but that target is heavily
restricted in cmake; this removes it and adds a check target that works
instead to run the test suite in the build.
---
CMakeLists.txt | 4 ----
test/CMakeLists.txt | 3 +++
2 files changed, 3 insertions(+), 4 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 79d60e1..054aa57 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -259,10 +259,6 @@ add_subdirectory(llarp)
add_subdirectory(libabyss)
add_subdirectory(daemon)
-if(WITH_TESTS)
- enable_testing()
-endif()
-
if (NOT SHADOW)
if(WITH_TESTS)
add_subdirectory(test)
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 22c7eff..57709c3 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -73,3 +73,6 @@ endif(NOT WIN32)
if(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
target_link_directories(${TEST_EXE} PRIVATE /usr/local/lib)
endif()
+
+add_custom_target(check COMMAND ${TEST_EXE})
+