lokinet/debian/patches/0002-Remove-setcap.patch
2019-07-25 20:23:25 -03:00

25 lines
865 B
Diff

From: Jason Rhinelander <jason@imaginary.ca>
Date: Thu, 25 Jul 2019 18:34:08 -0300
Subject: Remove setcap
The debian setcap is applied in postinst instead (and the setcap here
doesn't work with debian's temporary install location).
---
CMakeLists.txt | 3 ---
1 file changed, 3 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a51f123..5ead30f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -298,9 +298,6 @@ else()
install(PROGRAMS ${CMAKE_SOURCE_DIR}/lokinet-bootstrap DESTINATION bin)
endif()
- if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
- install(CODE "execute_process(COMMAND setcap cap_net_admin,cap_net_bind_service=+eip ${CMAKE_INSTALL_PREFIX}/bin/lokinet)")
- endif(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
if(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
target_link_directories(${EXE} PRIVATE /usr/local/lib)
endif()