mirror of
https://github.com/oxen-io/lokinet.git
synced 2024-11-17 15:25:35 +00:00
18d6942ffb
Drop 0004-lokimq-rename-compatibility-fix.patch: <REASON>
24 lines
755 B
Diff
24 lines
755 B
Diff
From: Jason Rhinelander <jason@imaginary.ca>
|
|
Date: Mon, 9 Sep 2019 22:12:03 -0300
|
|
Subject: Move default user/group into deb patch
|
|
|
|
Rather than cramming it into CXXFLAGS in debian/rules.
|
|
---
|
|
CMakeLists.txt | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 47a6014..8ef2af0 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -110,6 +110,9 @@ include(cmake/unix.cmake)
|
|
include(cmake/check_for_std_optional.cmake)
|
|
include(cmake/check_for_std_filesystem.cmake)
|
|
|
|
+# Unique user for system lokinet; _loki group is intentionally shared with the loki-core debs.
|
|
+add_definitions(-DDEFAULT_LOKINET_USER=\"_lokinet\" -DDEFAULT_LOKINET_GROUP=\"_loki\")
|
|
+
|
|
if(NOT WIN32)
|
|
if(IOS OR ANDROID)
|
|
set(NON_PC_TARGET ON)
|