You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gitwatch/gitwatch.nix

20 lines
356 B
Nix

{ runCommandNoCC
, lib
, makeWrapper
, git
, openssh
, inotify-tools
}: runCommandNoCC "gitwatch" {
nativeBuildInputs = [ makeWrapper ];
} ''
mkdir -p $out/bin
dest="$out/bin/gitwatch"
cp ${./gitwatch.sh} $dest
chmod +x $dest
patchShebangs $dest
wrapProgram $dest \
--prefix PATH ';' ${lib.makeBinPath [ git inotify-tools openssh ]}
''