You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gitwatch/flake.nix

20 lines
516 B
Nix

{
description = "A bash script to watch a file or folder and commit changes to a git repo";
outputs = { self, nixpkgs, flake-utils }:
let
packages = flake-utils.lib.eachDefaultSystem (system:
let
pkgs = import nixpkgs {
inherit system;
};
in
{
packages = rec {
gitwatch = pkgs.callPackage ./gitwatch.nix { };
default = gitwatch;
};
});
in
packages // { modules = [ ./module.nix ]; };
}